FreshBooks Classic - Component not working
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted May 27, 2020 - 09:32 EDT
Monitoring
We have fixed the issue impacting FreshBooks, but are seeing a delay in the sending of some emails. Feel free to check back here for any further updates.
Posted May 26, 2020 - 15:59 EDT
Update
There’s currently an issue with outbound emails on FreshBooks Classic. We’ve identified the problem and are working to fix it, however emails that are sent will not be delivered at this time. We expect these issues to continue into tomorrow morning. Please check back for further updates.
Posted May 25, 2020 - 21:11 EDT
Update
There’s currently an issue with outbound emails on FreshBooks. We’ve identified the problem and are working to fix it, however emails that are sent will not be delivered at this time. We expect these issues to continue into tomorrow morning. Please check back for further updates.
Posted May 25, 2020 - 20:56 EDT
Update
There’s currently an issue with outbound emails on FreshBooks. We’ve identified the problem and are working to fix it, however emails that are sent will not be delivered at this time. Once this issue is resolved, all queued emails will be delivered. Please check back for further updates.
Posted May 25, 2020 - 18:44 EDT
Identified
There’s currently an issue with outbound emails on FreshBooks Classic. We’ve identified the problem and are working to fix it, however emails that are sent will not be delivered at this time. Once this issue is resolved, all queued emails will be delivered. Please check back for further updates.
Posted May 25, 2020 - 18:35 EDT
This incident affected: FreshBooks and FreshBooks Classic.