Monitoring FreshBooks Issue
Incident Report for FreshBooks
Resolved
FreshBooks availability has been restored, New and Classic FreshBooks are now fully operational. We apologize for any inconveniences this may have caused.
Posted 7 months ago. Jan 30, 2019 - 12:23 EST
Monitoring
We are currently monitoring the issue affecting the availability of FreshBooks. We apologize for any inconvenience this may be causing. We will post another update when we have more information.
Posted 7 months ago. Jan 30, 2019 - 12:04 EST
This incident affected: FreshBooks and FreshBooks Classic.