FreshBooks - Investigating Issue
Incident Report for FreshBooks
Resolved
The issue we were experiencing with our third party email delivery partner has been fully resolved and requires no further monitoring. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Jun 25, 2020 - 10:30 EDT
Monitoring
The issue we were experiencing with our third party email delivery partner has been resolved. We will continue to monitor the situation to ensure there’s no further interruption to service. Feel free to check back here for any further updates.
Posted Jun 24, 2020 - 16:13 EDT
Investigating
We’re currently investigating reports of an issue with email delivery being delayed on FreshBooks. We will post updates as soon as we have them.
Posted Jun 24, 2020 - 14:38 EDT
This incident affected: FreshBooks and FreshBooks Classic.