FreshBooks Android App Is Unavailable
Incident Report for FreshBooks
Resolved
The Android app issue that made it unavailable for some users has been resolved. Please download the latest version (1.14.13). Note that you may need to log in again after the update.
Posted 9 months ago. Mar 15, 2018 - 06:36 EDT
Identified
FreshBooks is unavailable for Android users with the latest version of the app. We are working to fix this as quickly as possible. In the meantime, we recommend using the web app until the issue is resolved.
Posted 9 months ago. Mar 14, 2018 - 21:38 EDT