FreshBooks - Monitoring
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Sep 14, 2020 - 16:04 EDT
Monitoring
We have fixed the issue impacting FreshBooks, and will continue to monitor it to ensure there’s no further access issues. Feel free to check back here for any further updates.
Posted Sep 14, 2020 - 09:39 EDT
This incident affected: FreshBooks.