FreshBooks - Investigating Email Issue
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks Classic.

Thank you for your patience while we worked to fix the issue.
Posted Apr 08, 2020 - 16:57 EDT
Update
The issue impacting New FreshBooks where emails were delayed has been resolved.
Investigation is still ongoing into the emails sent from FreshBooks Classic yesterday. We are still seeing delays in these email being delivered and will continue to update you as soon as we know more.

Anything you send from your FreshBooks or FreshBooks Classic account now is unaffected.
Posted Apr 07, 2020 - 16:29 EDT
Update
The issue impacting New FreshBooks where emails were delayed in their delivery has been addressed and we will continue to monitor to ensure there are no further interruptions.

For FreshBooks Classic, we are still seeing delays in mail delivery. We are actively investigating and will continue to update as we progress.
Posted Apr 07, 2020 - 10:31 EDT
Identified
We have identified the issue impacting FreshBooks which is a result of errors and some sending delays our emailing partner is having.
They have identified the issue and are working on it.
We will post an update as soon as everything is resolved.
Posted Apr 06, 2020 - 17:15 EDT
Investigating
We’re currently investigating an issue with email delivery on our FreshBooks Classic platform. You may also experience a delay in delivery times with New FreshBooks emails.
We will post updates as soon as we have them.
Posted Apr 06, 2020 - 16:34 EDT
This incident affected: FreshBooks and FreshBooks Classic.