FreshBooks/FreshBooks Classic/FreshBooks Payments - Investigating Issue
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Feb 01, 2021 - 13:23 EST
Monitoring
We have fixed the issue impacting FreshBooks, and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Feb 01, 2021 - 12:54 EST
Update
We are continuing to investigate this issue.
Posted Feb 01, 2021 - 11:50 EST
Investigating
We’re currently investigating reports of an issue with FreshBooks Payment and FreshBooks Classic. We will post updates as soon as we have them.
Posted Feb 01, 2021 - 11:45 EST
This incident affected: FreshBooks, FreshBooks Classic, and FreshBooks Payments.