New FreshBooks/FreshBooks Classic Access
Incident Report for FreshBooks
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 04, 2019 - 12:02 EDT
Update
We are continuing to investigate this issue.
Posted 2 months ago. Apr 04, 2019 - 11:36 EDT
Update
We are continuing to investigate the cause of the downtime.
Posted 2 months ago. Apr 04, 2019 - 11:36 EDT
Investigating
Currently we are experiencing degraded performance which is impacting the availability of New FreshBooks and FreshBooks Classic. We apologize for the inconvenience and are investigating the cause. Please check back for updates.
Posted 2 months ago. Apr 04, 2019 - 11:23 EDT
This incident affected: FreshBooks and FreshBooks Classic.