Phone System Issue
Incident Report for FreshBooks
Resolved
The issue with our phone system has now been resolved.
Posted Nov 03, 2020 - 16:31 EST
Investigating
We are currently experiencing an issue with our phone system and calls are not able to get through. Please email us at support@freshbooks.com
Posted Nov 03, 2020 - 16:19 EST
This incident affected: FreshBooks, FreshBooks Classic, Automatic Expense Import, and FreshBooks Payments.