FreshBooks - Investigating Email Issue
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Mar 05, 2021 - 18:36 EST
Investigating
We are currently experiencing some internal issues and as a result you can expect to see slower than normal delivery of emails.
Posted Mar 05, 2021 - 15:57 EST
This incident affected: FreshBooks and FreshBooks Classic.