FreshBooks Classic - Identified
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks Classic. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Nov 11, 2020 - 12:10 EST
Identified
We have identified an issue impacting FreshBooks Classic Invoices. You may notice upon saving a new Invoice that your line Items are no longer present. This is a delay issue which will resolve itself in about 10 minutes. We are working to fix it and will post an update as soon as everything is resolved.
Posted Nov 10, 2020 - 20:02 EST
This incident affected: FreshBooks Classic.