FreshBooks - Monitoring Issue
Incident Report for FreshBooks
Resolved
This incident has been resolved.
Posted Nov 10, 2020 - 15:02 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 10, 2020 - 10:44 EST
Investigating
We’re currently investigating reports of an issue with Bank Import and the Expense Page on FreshBooks. We will post updates as soon as we have them.
Posted Nov 10, 2020 - 09:35 EST
This incident affected: FreshBooks and Automatic Expense Import.