FreshBooks Classic - Access issues
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting the performance of FreshBooks Classic. Some customers may find their payment information was slow to update, but please reach out to FreshBooks Support if you encounter any issues going forward. Thank you for your patience while we worked to fix the issue.
Posted Jan 15, 2020 - 10:06 EST
Monitoring
The cause of the issue impacting FreshBooks and FreshBooks Classic has been identified and we believe the problem has been resolved. We have set up additional monitoring over night to ensure the issue is fixed and will update in the morning to confirm.
Posted Jan 14, 2020 - 19:29 EST
Identified
We’re currently experiencing an issue which may cause some slowness in FreshBooks and FreshBooks Classic, particularly related to payments information. We're working with our payments partner to resolve this quickly. We will post another update as soon as we have more information.
Posted Jan 14, 2020 - 15:54 EST
This incident affected: FreshBooks, FreshBooks Classic, and FreshBooks Payments.