Phone System Issue
Incident Report for FreshBooks
Resolved
Customer calls are connecting to Support without issue.
Posted Dec 10, 2021 - 16:53 EST
Update
We are seeing the system recover and calls are connecting as expected. We will continue to monitor and update as this progresses.
Posted Dec 10, 2021 - 16:15 EST
Investigating
We are currently investigating an issue with our call provider which is resulting in some customer calls not connecting to Support.
Posted Dec 10, 2021 - 16:12 EST
This incident affected: FreshBooks.