FreshBooks - Access Issues
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Oct 07, 2021 - 14:42 EDT
Monitoring
We have identified and resolved the issue impacting FreshBooks, and will continue to monitor to ensure there’s no further issues. Feel free to check back here for any further updates.
Posted Oct 06, 2021 - 10:14 EDT
Update
We have identified the issue impacting FreshBooks, and are working quickly to resolve it. At this time, we continue to experience issues with a specific service operating at a reduced rate of processing. You may experience delays loading the team's page and the time-entry page. We are working to resolve this issue.
Posted Oct 06, 2021 - 09:32 EDT
Update
We have identified the issue impacting FreshBooks, and are working quickly to resolve it. At this time, we continue to experience issues with a specific service operating at a reduce rate of processing. You may experience delays with comment threads, removing team members from projects, and notifications and emails for late reminders and payment processing.
Posted Oct 05, 2021 - 14:42 EDT
Identified
We have identified the issue impacting FreshBooks, and are working quickly to resolve it. We will post an update as soon as everything is resolved.
Posted Oct 05, 2021 - 13:55 EDT
Investigating
We’re currently experiencing an issue which is causing intermittent performance issues. As a result, you may experience degraded performance in your FreshBooks account. We will post another update as soon as we have more information.
Posted Oct 05, 2021 - 12:34 EDT
Monitoring
We have fixed the issue impacting FreshBooks, and will continue to monitor it to ensure there’s no further issues. Feel free to check back here for any further updates.
Posted Oct 04, 2021 - 12:50 EDT
Identified
We have identified the issue impacting FreshBooks, and are working quickly to fix it. We will post an update as soon as everything is resolved.
Posted Oct 04, 2021 - 12:46 EDT
Investigating
We’re currently experiencing an issue which may prevent users from accessing FreshBooks. As a result, you may experience problems with your login while we work to fix the problem. We will post another update as soon as we have more information.
Posted Oct 04, 2021 - 11:26 EDT
This incident affected: FreshBooks and FreshBooks Classic.