FreshBooks Classic - Degraded Performance
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks Classic. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Jul 08, 2021 - 17:37 EDT
Monitoring
We have fixed the issue impacting FreshBooks Classic, and will continue to monitor it to ensure there’s no further degraded performance. Feel free to check back here for any further updates.
Posted Jul 08, 2021 - 13:11 EDT
Identified
We have identified the issue causing Degraded FreshBooks Classic Performance, and are seeing improvements in performance as we continue to work on resolving this issue. We will continue to post updates as we continue to work towards completely resolving the issue.
Posted Jul 08, 2021 - 11:53 EDT
Investigating
We’re currently investigating reports of degraded performance on FreshBooks Classic and an issue impacting Invoice & Estimate Logos. We will post updates as soon as we have them.
Posted Jul 08, 2021 - 11:26 EDT
This incident affected: FreshBooks Classic.