FreshBooks - Access Issues
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Aug 03, 2021 - 09:56 EDT
Monitoring
We have fixed the issue impacting FreshBooks and we'll continue to monitor it to ensure there’s no further downtime.
Posted Aug 02, 2021 - 15:39 EDT
Identified
We have identified the issue that is impacting FreshBooks customers ability to access and navigate within their accounts and we are working quickly to fix it. We will post an update as soon as everything is resolved.
Posted Aug 02, 2021 - 15:25 EDT
Investigating
We’re currently experiencing an issue which may prevent users from accessing their FreshBooks accounts consistently. As a result, you may experience problems with your login and navigating within your account while we work to fix the problem. We will post another update as soon as we have more information.
Posted Aug 02, 2021 - 15:10 EDT
This incident affected: FreshBooks.