FreshBooks - Subscription Changes
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks subscription changes. Thank you for your patience while we worked to fix the issue! Check back here for any further updates.
Posted Jun 08, 2021 - 18:50 EDT
Monitoring
We have fixed the issue impacting FreshBooks subscription changes, and will continue to monitor it to ensure there’s no further impact on our customers' ability to change their FreshBooks subscription. Feel free to check back here for any further updates.
Posted Jun 08, 2021 - 14:57 EDT
Investigating
We are currently investigating an issue with subscription changes. Customers may be unable to upgrade, downgrade or successfully cancel their account at this time. Please check back for further updates.
Posted Jun 08, 2021 - 13:50 EDT
This incident affected: FreshBooks and FreshBooks Classic.