FreshBooks - Component not working
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks' Client Relationship feature/tab. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Oct 27, 2021 - 14:29 EDT
Monitoring
We have fixed the issue impacting the Client Relationship feature in the New FreshBooks, and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Oct 21, 2021 - 17:23 EDT
Investigating
There’s currently an issue with our Client Relationship feature, where the Relationship history is currently not loading / being displayed on FreshBooks. We’ve identified the problem and are working to fix it, however you may be unable to load the Client Relationship tab at this time. Please check back for further updates.
Posted Oct 21, 2021 - 16:12 EDT
This incident affected: FreshBooks, FreshBooks Classic, Automatic Expense Import, FreshBooks Payments, Android App, and iOS App.