FreshBooks - Investigating Issue
Incident Report for FreshBooks
Resolved
The issue impacting one of our email providers for FreshBooks has been resolved. Thank you for your patience.
Posted Jul 31, 2020 - 08:04 EDT
Monitoring
We are continuing to monitor the ongoing issue with one of our email delivery providers. FreshBooks features requiring email delivery should go out as expected. We will post updates as soon as we have them.
Posted Jul 28, 2020 - 17:26 EDT
Investigating
We’re currently investigating reports of an issue with one of our email providers for FreshBooks. Some email delivery will be impacted or disrupted. We will post updates as soon as we have them.
Posted Jul 28, 2020 - 10:44 EDT
This incident affected: FreshBooks.