FreshBooks - Component not working
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Feb 20, 2021 - 08:09 EST
Identified
There’s currently a delay issue with projects, time tracked and their billing statuses. Please check back for further updates.
Posted Feb 19, 2021 - 18:51 EST
This incident affected: FreshBooks.