FreshBooks - Investigating Issue
Incident Report for FreshBooks
Postmortem

Earlier today FreshBooks updated an internal system which resulted in an inability for customers to access the system. We resolved the issue by rolling back the update.

Posted Feb 06, 2020 - 10:18 EST

Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Feb 06, 2020 - 10:17 EST
Update
We are continuing to monitor for any further issues.
Posted Feb 06, 2020 - 10:17 EST
Monitoring
We have fixed the issue impacting FreshBooks, and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Feb 06, 2020 - 10:08 EST
Identified
We have identified the issue impacting FreshBooks, and are working quickly to fix it. We will post an update as soon as everything is resolved.
Posted Feb 06, 2020 - 09:39 EST
Update
FreshBooks is currently down, and our team is working hard to get it back up and running. We will post updates as soon as we have them.
Posted Feb 06, 2020 - 09:38 EST
Investigating
We’re currently investigating reports of an issue withFreshBooks. We will post updates as soon as we have them.
Posted Feb 06, 2020 - 09:33 EST
This incident affected: FreshBooks and FreshBooks Classic.