FreshBooks - Trial Upgrades and Reactivation Disabled
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting Trial upgrades and account reactivation. Thank you for your patience while we worked to fix the issue.
Posted May 31, 2021 - 17:12 EDT
Monitoring
We have fixed the issue impacting Trial upgrades and account reactivation. We'll continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted May 31, 2021 - 15:52 EDT
Identified
At this time, FreshBooks Trial accounts cannot upgrade and deactivated accounts cannot reactivate. We have identified the issue causing this problem and are working quickly to fix it. We will post an update as soon as everything is resolved.
Posted May 31, 2021 - 13:11 EDT
This incident affected: FreshBooks.