FreshBooks - Delayed Recurring Invoice Generation
Incident Report for FreshBooks
Resolved
We have resolved the issue with delayed Recurring Invoice Generation on FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Oct 01, 2021 - 23:15 EDT
Update
We're still monitoring the progress of our resolution regarding Delayed Recurring Invoice Generation and we expect to see it fully resolved by this evening. Feel free to check back here for any further updates.
Posted Oct 01, 2021 - 14:46 EDT
Monitoring
We have fixed the issue impacting Recurring Invoice Generation and will continue to monitor it to ensure there’s no further delays. Feel free to check back here for any further updates.
Posted Oct 01, 2021 - 12:09 EDT
Update
We have identified the issue impacting Recurring Invoice Generation and we are working quickly to fix it. We will post an update as soon as everything is resolved.
Posted Oct 01, 2021 - 10:56 EDT
Investigating
There’s currently an issue with delays concerning Recurring Invoice Generation on FreshBooks. We're investigating the cause of this delay and we will continue to provide updates throughout our investigation. Please check back for further updates.
Posted Oct 01, 2021 - 10:00 EDT
This incident affected: FreshBooks.