FreshBooks - Down
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Dec 23, 2019 - 12:22 EST
Monitoring
We have fixed the issue impacting FreshBooks, and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Dec 23, 2019 - 10:57 EST
Investigating
FreshBooks is currently down, and our team is working hard to get it back up and running. We will post updates as soon as we have them.
Posted Dec 23, 2019 - 10:12 EST
This incident affected: FreshBooks and FreshBooks Classic.