We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Mar 16, 2021 - 07:22 EDT
Monitoring
Access to FreshBooks is restored for users. We will continue to monitor the situation. Feel free to check back here for any further updates.
Posted Mar 15, 2021 - 22:22 EDT
Investigating
We’re currently experiencing an issue which may prevent users from accessing FreshBooks. As a result, you may experience problems with your login while we work to fix the problem. We will post another update as soon as we have more information.