FreshBooks - Access Issues
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Mar 16, 2021 - 16:14 EDT
Monitoring
We have fixed the issue impacting FreshBooks, and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Mar 16, 2021 - 16:05 EDT
Identified
We’re currently experiencing an issue which may prevent users from accessing FreshBooks. As a result, you may experience problems with your login while we work to fix the problem. We will post another update as soon as we have more information.
Posted Mar 16, 2021 - 15:30 EDT
This incident affected: FreshBooks.