FreshBooks Classic Access
Incident Report for FreshBooks
Resolved
FreshBooks Classic is now operating normally.
Posted over 1 year ago. Jun 20, 2017 - 18:07 EDT
Monitoring
Access to FreshBooks Classic appears to be recovering.
Posted over 1 year ago. Jun 20, 2017 - 17:56 EDT
Investigating
We're currently investigating reports of degraded performance for the FreshBooks Classic service.
Posted over 1 year ago. Jun 20, 2017 - 16:37 EDT