FreshBooks - Access Issues
Incident Report for FreshBooks
Resolved
The access issues we were experiencing have now been resolved. Thank you for your patience while we worked to fix the issue.
Posted Sep 30, 2021 - 17:01 EDT
Monitoring
A fix for the access issues has been implemented and we are monitoring the results.
Posted Sep 30, 2021 - 16:30 EDT
Investigating
We’re currently experiencing an issue that may prevent a small number of users from accessing FreshBooks. As a result, you may experience problems with your login or accessing the invoices page, while we work to fix the problem. We will post another update as soon as we have more information.
Posted Sep 30, 2021 - 16:00 EDT
This incident affected: FreshBooks.