FreshBooks Classic - Down
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks Classic. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Mar 11, 2020 - 14:01 EDT
Monitoring
We have fixed the issue impacting certain FreshBooks Classic accounts and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Mar 11, 2020 - 13:48 EDT
Identified
FreshBooks Classic is currently down for some accounts, and our team is working hard to get it back up and running. We will post updates as soon as we have them.
Posted Mar 11, 2020 - 13:30 EDT
This incident affected: FreshBooks Classic.