FreshBooks Classic - Investigating Issue
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks Classic. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Mar 02, 2020 - 11:16 EST
Monitoring
We have fixed the issue impacting FreshBooks Classic, and will continue to monitor it to ensure there’s no further issues. Feel free to check back here for any further updates.
Posted Mar 02, 2020 - 11:10 EST
Investigating
We’re currently investigating reports of an issue with Invoices on FreshBooks Classic. We will post updates as soon as we have them.
Posted Mar 02, 2020 - 11:02 EST
This incident affected: FreshBooks Classic.