FreshBooks Classic
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks Classic. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Nov 03, 2021 - 16:52 EDT
Identified
We have identified the issue impacting FreshBooks Classic, and are working quickly to fix it. We will post an update as soon as everything is resolved.
Posted Nov 03, 2021 - 14:28 EDT
Update
We are continuing to investigate this issue.
Posted Nov 03, 2021 - 13:03 EDT
Investigating
We are currently investigating an issue impacting the Classic FreshBooks service where newly created data such as invoices may be missing items and payment details.
Posted Nov 03, 2021 - 12:57 EDT
This incident affected: FreshBooks Classic.