FreshBooks - Investigating Issue
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates
Posted Mar 12, 2021 - 04:50 EST
Investigating
There’s currently an issue with email delivery being delayed on FreshBooks. We are investigating the issue and are working to fix it, however you may notice delays in emails being sent at this time. Please check back for further updates.
Posted Mar 12, 2021 - 03:26 EST
This incident affected: FreshBooks and FreshBooks Classic.