FreshBooks - Extreme Latency
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting access to FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Oct 01, 2021 - 18:00 EDT
Monitoring
We have fixed the issue impacting FreshBooks, and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Oct 01, 2021 - 17:05 EDT
Update
FreshBooks is currently down, and our team is working hard to get it back up and running. We will post updates as soon as we have them.
Posted Oct 01, 2021 - 16:43 EDT
Investigating
FreshBooks is currently experiencing extreme latency and our team is working hard to get it back up and running. At this time users can expect slowness and occasional difficulty logging into their accounts. We will post updates as soon as we have them.
Posted Oct 01, 2021 - 16:38 EDT
This incident affected: FreshBooks, FreshBooks Classic, Android App, and iOS App.