Freshbooks Unavailable
Incident Report for FreshBooks
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 08:55 EDT
Update
Our Content Delivery Network provider Fastly has identified the problem and is implementing a fix. Customers may be able to access Freshbooks, but may experience occasional unavailability.
Posted Jun 08, 2021 - 06:56 EDT
Monitoring
Our Content Delivery Network provider Fastly has identified the problem and is implementing a fix. Customers may be able to access Freshbooks, but may experience intermittent issues.
Posted Jun 08, 2021 - 06:56 EDT
Investigating
FreshBooks is currently down due to an issue with our Content Delivery Network Provider, Fastly.

Customers may be unable to access their accounts. Our team is working hard to get it back up and running. We will post updates as soon as we have them.
Posted Jun 08, 2021 - 06:47 EDT
This incident affected: FreshBooks, FreshBooks Classic, Automatic Expense Import, FreshBooks Payments, Android App, and iOS App.