FreshBooks - Payment processing currently unavailable
Incident Report for FreshBooks
Postmortem

We made an internal DNS change that conflicted with our payment systems.

Automated systems detected the problem and we reverted the DNS changes which took some time to propagate and restore service to all customers.

Posted Nov 12, 2019 - 17:09 EST

Resolved
We have resolved the issue impacting payments on FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Nov 12, 2019 - 17:09 EST
Monitoring
We have fixed the issue impacting payments on FreshBooks, and will continue to monitor it to ensure there’s no further issues. This will take a few moments to roll out to all accounts. Feel free to check back here for any further updates.
Posted Nov 12, 2019 - 16:55 EST
Identified
We have identified the issue impacting payments on FreshBooks, and are working quickly to fix it. We will post an update as soon as everything is resolved.
Posted Nov 12, 2019 - 16:37 EST
Investigating
There’s currently an issue with payment processing on FreshBooks. We are working to fix it, however you will not be able to process payments on FreshBooks at this time. Please check back for further updates.
Posted Nov 12, 2019 - 16:25 EST
This incident affected: FreshBooks, FreshBooks Classic, and FreshBooks Payments.