FreshBooks Classic - Degraded Performance
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks Classic Search and PDF endpoints. Thank you for your patience while we worked to fix the issue.
Posted Mar 31, 2020 - 19:49 EDT
Monitoring
We have fixed the issue impacting FreshBooks Classic Search and PDF, and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Mar 31, 2020 - 19:14 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 31, 2020 - 17:14 EDT
Update
We are continuing to investigate this issue.
Posted Mar 31, 2020 - 16:13 EDT
Update
FreshBooks Classic and New FreshBooks is currently down, and our team is working hard to get it back up and running. We will post updates as soon as we have them.
Posted Mar 31, 2020 - 16:03 EDT
Update
FreshBooks is currently down, and our team is working hard to get it back up and running. We will post updates as soon as we have them.
Posted Mar 31, 2020 - 16:03 EDT
Investigating
There’s currently an issue with Search and PDF endpoints on FreshBooks Classic. We’ve identified the problem and are working to fix it, however you may notice performance issues with our Search and PDF endpoints at this time. Please check back for further updates.
Posted Mar 31, 2020 - 15:40 EDT
This incident affected: FreshBooks and FreshBooks Classic.