FreshBooks - Access Issues
Incident Report for FreshBooks
Resolved
We have resolved the issue that was impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Oct 28, 2021 - 17:00 EDT
Investigating
We’re currently experiencing an issue that may prevent users from accessing FreshBooks intermittently. As a result, you may experience problems with your login while we work to fix the problem. We will post another update as soon as we have more information.
Posted Oct 28, 2021 - 16:19 EDT
This incident affected: FreshBooks.