FreshBooks Currently Unavailable
Incident Report for FreshBooks
Resolved
FreshBooks availability has been restored, New and Classic FreshBooks are now fully operational. We apologize for any inconvenience this may have caused.
Posted 4 months ago. Jan 04, 2019 - 13:00 EST
Investigating
We are currently experiencing degraded performance with our FreshBooks application. We apologize for the inconvenience and are investigating the cause. Please check back for updates.
Posted 4 months ago. Jan 04, 2019 - 11:01 EST
This incident affected: FreshBooks and FreshBooks Classic.