Scheduled Maintenance
Incident Report for FreshBooks
Resolved
FreshBooks availability has been restored,FreshBooks and FreshBooks Classic are now fully operational. Thank you for your patience.
Posted 12 months ago. Nov 06, 2018 - 08:03 EST
Monitoring
FreshBooks is undergoing scheduled maintenance. We’re sorry for any inconvenience this may be causing. We will post a final update once maintenance is complete.
Posted 12 months ago. Nov 06, 2018 - 07:31 EST
Identified
FreshBooks and FreshBooks Classic are undergoing scheduled maintenance. Thank you for your patience. We’ll be back to business at 9am ET.
Posted 12 months ago. Nov 06, 2018 - 05:59 EST
This incident affected: FreshBooks, FreshBooks Classic, Automatic Expense Import, and FreshBooks Payments.