FreshBooks Payments temporarily unavailable
Incident Report for FreshBooks
Resolved
Our payment provider has restored service and the issue with FreshBooks Payments has been resolved.
Posted almost 2 years ago. Mar 15, 2017 - 17:27 EDT
Identified
Due to an issue at our payment partner, FreshBooks Payments is temporarily unavailable. We're in touch with the partner and working on resolution.
Posted almost 2 years ago. Mar 15, 2017 - 16:44 EDT