FreshBooks Maintenance
Incident Report for FreshBooks
Resolved
FreshBooks maintenance is complete. We're back in business.
Posted 9 months ago. Mar 07, 2018 - 18:22 EST
Monitoring
FreshBooks is undergoing planned maintenance. We are expected to get you back to business as usual by 6:30PM ET.
Posted 9 months ago. Mar 07, 2018 - 17:55 EST