FreshBooks - FreshBooks Payments high decline rate
Incident Report for FreshBooks
Resolved
The issue impacting FreshBooks Payments has been resolved. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Nov 19, 2021 - 16:22 EST
Update
The issue impacting FreshBooks Payments has been fixed by our payments partner, and we will continue to monitor it to ensure there are no further issues with payments processed via FreshBooks Payments. Feel free to check back here for updates.
Posted Nov 19, 2021 - 13:10 EST
Monitoring
The issue impacting FreshBooks Payments has been fixed by our payments partner, and we will continue to monitor it to ensure there are no further issues with payments processed via FreshBooks Payments. Feel free to check back here for updates.
Posted Nov 19, 2021 - 13:09 EST
Identified
There’s currently an issue affecting FreshBooks Payments. We’ve identified the problem as being with our payment partner, and they are working to fix it. You may find payments declining at a higher rate.
Posted Nov 19, 2021 - 12:09 EST
This incident affected: FreshBooks and FreshBooks Payments.