FreshBooks - Access Issues
Incident Report for FreshBooks
Postmortem

An internal tool used as part of our load testing systems was misconfigured. This caused excessive load on our authentication systems which prevented access to FreshBooks. We have made internal process changes to ensure this doesn't happen again.

Posted Feb 20, 2020 - 15:30 EST

Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Feb 20, 2020 - 13:57 EST
Monitoring
We believe we have fixed the issue impacting FreshBooks, and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Feb 20, 2020 - 13:52 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 20, 2020 - 13:25 EST
Investigating
We’re currently experiencing an issue which may prevent users from accessing FreshBooks. As a result, you may experience problems with your login while we work to fix the problem. We will post another update as soon as we have more information.
Posted Feb 20, 2020 - 13:12 EST
This incident affected: FreshBooks and FreshBooks Classic.