FreshBooks Service Outage 2019-06-24
Incident Report for FreshBooks
Resolved
This incident has now been resolved! FreshBooks services are available and operating normally.
Posted 4 months ago. Jun 24, 2019 - 12:38 EDT
Update
We have identified the cause of our recent outage and are continuing to monitor the situation to ensure continued access and accessibility.
Posted 4 months ago. Jun 24, 2019 - 11:52 EDT
Monitoring
We are continuing to investigate our most recent outage and are monitoring the situation. Further updates will be provided as we continue to work towards a solution.
Posted 4 months ago. Jun 24, 2019 - 11:11 EDT
Investigating
FreshBooks is currently unavailable and we are investigating solutions to resolve the issue as soon as possible.
Posted 4 months ago. Jun 24, 2019 - 10:46 EDT
This incident affected: FreshBooks and FreshBooks Classic.