FreshBooks Classic - Loading Issues
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks Classic. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Jan 28, 2021 - 08:46 EST
Monitoring
We have fixed the issue impacting FreshBooks Classic, and will continue to monitor it to ensure there’s no further downtime. Feel free to check back here for any further updates.
Posted Jan 27, 2021 - 09:17 EST
Identified
We have identified the issue impacting FreshBooks Classic, and are working towards a resolution. We will post an update as soon as we have more information.
Posted Jan 26, 2021 - 16:12 EST
Investigating
We’re currently experiencing an issue which may prevent users from loading their FreshBooks Classic accounts properly. As a result, you may experience problems with accessing features within your Classic account. We are investigating the cause and will update as soon as we have more information.
Posted Jan 26, 2021 - 15:07 EST
This incident affected: FreshBooks Classic.