#may03-invoice-creation-failing

Incident Report for FreshBooks

Resolved

We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted May 05, 2023 - 13:59 EDT

Monitoring

A fix has been implemented and we will continue to monitor the results.
Posted May 03, 2023 - 08:32 EDT

Identified

The issue causing invoice creation and invoice editing has been identified and a fix is being implemented.
Posted May 03, 2023 - 08:23 EDT

Update

We are continuing to investigate an issue related to invoice creation and editing. Our iOS and Android apps are performing as expected.
Posted May 03, 2023 - 08:18 EDT

Investigating

We are currently investigating an issue related to invoice creation and invoice editing. Further updates will be provided as we navigate this issue and determine a solution.
Posted May 03, 2023 - 08:09 EDT
This incident affected: FreshBooks, Android App, and iOS App.