Phone System Issue
Incident Report for FreshBooks
Resolved
The issue we were experiencing with our phone system has now been resolved.
Posted Jan 04, 2021 - 11:33 EST
Investigating
We are currently investigating an issue with our phone system and phone support is not available at this time. Please email us at support@freshbooks.com in the meantime.
Posted Jan 04, 2021 - 11:02 EST