Payment gateway issues
Incident Report for FreshBooks
Resolved
We have resolved the issue impacting FreshBooks. Thank you for your patience while we worked to fix the issue. Check back here for any further updates.
Posted Jun 18, 2024 - 03:16 EDT
Monitoring
We have fixed the issue impacting Online Payments and will continue monitoring it to ensure no further downtime. Feel free to check back here for any further updates.
Posted Jun 17, 2024 - 15:42 EDT
Investigating
We are currently experiencing an issue with processing Online Payments. The team is aware of the problem and is working to resolve it, but you may notice issues with processing payments and entering payment information manually. We will post another update as soon as we have more information.
Posted Jun 17, 2024 - 14:56 EDT