FreshBooks - Identified
Incident Report for FreshBooks
Resolved
This incident has been resolved.
Posted Sep 26, 2023 - 08:46 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2023 - 08:38 EDT
Identified
We have identified the issue impacting FreshBooks, and are working quickly to fix it. In the meantime you may encounter slowness logging in. As soon as the issue is resolved we will update here.
Posted Sep 26, 2023 - 08:25 EDT
This incident affected: FreshBooks.